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This Quick Start Guide provides an overview of how to use the Feature 
Extraction for CytoGenomics software as a stand- alone program, with 
step- by- step instructions on how to start the program and run an 
extraction. Although it is not normally necessary to run the Feature 
Extraction program separately, reading the information in this guide can 
help you understand how Agilent CytoGenomics extracts data from images 
during a workflow. For a complete description of the Feature Extraction 
main window and its components, see the Feature Extraction for 
CytoGenomics Users Guide.
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What is Agilent Feature Extraction for CytoGenomics software?
What is Agilent Feature Extraction for CytoGenomics software?

The Feature Extraction for CytoGenomics software is installed as part of 
the Agilent CytoGenomics software package. Normally, it runs in the 
background to automatically extract microarray images in Agilent 
CytoGenomics workflows. It finds and adjusts microarray grids, rejects 
outlier pixels, accurately calculates feature intensities and ratios, flags 
outlier features, and calculates statistical confidences. The extracted 
microarray files are then analyzed by the Agilent CytoGenomics software.

It is not necessary to run the Feature Extraction program separately, 
except in the following situations:

• Automatic grid placement for a microarray failed and requires manual 
grid adjustment

• Changes to a protocol are required

Agilent Feature Extraction software extracts data from microarray images 
produced in three different situations:

• Agilent microarrays scanned on an Agilent scanner

• Agilent microarrays scanned on a supported non- Agilent scanner (i.e. 
Roche NimbleGen MS 200 scanners, select Innopsys InnoScan scanners, 
and select Tecan scanners)

• Non- Agilent microarrays scanned on an Agilent scanner (only if the 
necessary protocol is imported into Feature Extraction for 
CytoGenomics; download protocols from www.agilent.com/genomics)

Feature Extraction handles each of these images differently. These 
differences are described throughout the documentation.

If you are a new user
Read “Getting Help” on page 4.

If you intend to analyze...

• Saved Agilent images, read the “Instructional overview” on page 10.

• Saved non- Agilent images, read the “Instructional overview” on page 10.

• Agilent images in real time, read the “Instructional overview” on 
page 20, and go to “General Instructions” on page 21.
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About installed grid templates, protocols, and QC metric sets
About installed grid templates, protocols, and QC metric sets
When Feature Extraction for CytoGenomics is installed as part of the 
installation of Agilent CytoGenomics, a standard set of Feature Extraction 
grid templates, protocols, and QC metric sets are also included in the 
database. These are displayed when you open Feature Extraction for 
CytoGenomics.

Grid templates (design files) cannot be imported from within the Feature 
Extraction for CytoGenomics program; they must be imported as design 
files from within the Agilent CytoGenomics program. See the 
CytoGenomics help system for more information.

To update the list of displayed files
Design files and QC metric sets that were created or imported in Agilent 
CytoGenomics are automatically displayed in Feature Extraction for 
CytoGenomics when you start the program. Also, protocols and QC Metric 
Sets that were created or imported from within the Feature Extraction for 
CytoGenomics program are automatically displayed within the Agilent 
CytoGenomics program.

To update the list of files displayed in the Feature Extraction for 
CytoGenomics browsers,

• Right- click in the Grid Template, Protocol, or QC Metric Set Browser, 
and then select Refresh.
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Getting Help
Getting Help

To get help for Feature Extraction for CytoGenomics
The following tables list the resources available for getting help. Guides 
and manuals are opened using Adobe® Reader® software. 

Help Resource Description/Instructions

Feature Extraction Quick Start 
Guide

This guide, which you are reading, gives you an overview of the 
Feature Extraction software, including tutorial exercises. To open 
this guide from within Feature Extraction for CytoGenomics click 
Help > Quick Start Guide.

Feature Extraction User Guide A comprehensive guide for using the Feature Extraction software, 
that includes the following chapters:

• Chapter 1– Working with Feature Extraction
• Chapter 2– Extracting Microarrays Automatically
• Chapter 3– Creating Grid Files and Templates
• Chapter 4– Changing Protocol Settings
• Chapter 5– Changing Image Displays
To open this guide from within Feature Extraction, click Help > 
User Guide.

Feature Extraction Reference 
Guide

A reference guide that contains information about protocols, QC 
reports, results, and algorithms, that includes the following 
chapters:

• Chapter 1 – Default Protocol Settings
• Chapter 2 – QC Report Results
• Chapter 3 – Text File Parameters and Results
• Chapter 4 – MAGE-ML Results
• Chapter 5 – How Algorithms Calculate Results
To open this guide from within Feature Extraction, click Help > 
Reference Guide.

Technical Support Opens a link to the Agilent Technical Support Web site where you 
can find literature and manuals, view Frequently Asked Questions, 
and download updates and revision information. There is also a 
Contact Us link where you can locate the technical support phone 
number or send an e-mail to technical support for your country.
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To learn about Agilent products and services
To learn about Agilent products and services
To view information about the Genomics products and services that are 
available from Agilent, go to www.genomics.agilent.com. To view 
information about the Life Sciences and Chemical Analysis products and 
services that are available from Agilent, go to www.chem.agilent.com.

Feature Extraction Training Opens a link to the Feature Extraction Tutorials Web Site, where 
you can view a number of self-paced instructional tutorials.

To open this Web site from within Feature Extraction, click Help > 
Feature Extraction Training.

Feature Extraction on the Web Opens a menu that provides links to the following:

• Array annotation – Find available design files by barcode
• Feature Extraction Software – Feature Extraction software 

downloads and information
• Feature Extraction Protocols – Download current and previous 

versions of Feature Extraction protocols

Agilent License Opens the Agilent software license redemption Web site, where 
you use your entitlement certificate to redeem your software 
license.

Memory Status Opens an information window that shows how much computer 
memory is currently available and how much memory is in use.

About Opens an information window that shows your Feature Extraction 
version, license, and database information. This window also 
displays your computer Host ID, which you need in order to redeem 
your license.

Help Resource Description/Instructions
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Starting the program
Starting the program

Feature Extraction for CytoGenomics is installed when you install the 
Agilent CytoGenomics software. A shortcut is not installed for the Feature 
Extraction for CytoGenomics software.

To start Feature Extraction for CytoGenomics:

• From Windows, click Start > All Programs > Agilent 
CytoGenomicsEdition 2.5.x.x > Agilent Feature Extraction for 
CytoGenomics.

Now you see the Feature Extraction for CytoGenomics main window.

CAUTION If you install Agilent Genomic Workbench and Agilent CytoGenomics on 
the same computer, each program installs its own version of Feature 
Extraction. Do not confuse Feature Extraction with Feature Extraction for 
CytoGenomics. A shortcut appears only for Feature Extraction version 
10.10 (used with Agilent Genomic Workbench.)
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Starting the program
Figure 1 Feature Extraction for CytoGenomics main window
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To open an image file
To open an image file
1 With the Feature Extraction for CytoGenomics main window open, click 

File > Open > Image, and browse to the folder that contains the image 
file. Double- click the image file (.tif) that you want to open. 

If the Feature Extraction for CytoGenomics program is running, you can 
also “drag and drop” the image from your folder to the open Feature 
Extraction window.

Figure 2 Feature Extraction for CytoGenomics Main Window with open image

NOTE For high resolution images (2 or 3 micron or 20-bit), you see a low-resolution preview image 
until you crop to roughly 1/10 of the preview image size. Then you see the original 
high-resolution image. [The Crop Cursor turns red when you are outside the high-resolution 
(High Fidelity) region.]

Image Toolbar

Image Window
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To open an image file
To learn more about interactively finding spots and creating grid files for 
non- Agilent images, see Chapter 3, “Creating Grid Files”, in the Feature 
Extraction for CytoGenomics User Guide.

To learn more about changing the image display, see Chapter 5, “Changing 
Image Displays”, in the Feature Extraction for CytoGenomics User Guide.
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Setting up a Standard Project to extract Agilent and non-Agilent image files
Setting up a Standard Project to extract Agilent and non-Agilent image 
files

Instructional overview
Follow the road map below and the instructions on the next pages to get 
started.

See Chapter 2 in the Feature Extraction for CytoGenomics User Guide 
for details on this task.

The Agilent Feature Extraction for CytoGenomics program works with 
Agilent or non- Agilent microarray images produced on Agilent scanners, 
and Agilent microarray images produced on non- Agilent scanners, using 
projects, extraction sets, grid templates or files, and protocols. The images 
are organized into extraction sets that contain the grid and protocol 
information to run the extraction. The extraction sets, in turn, are 
organized into projects.

Start 
Here!

Set up and 
run saved 
image files

3 Add image files 
(extraction 
sets)

1 Create a 
“Standard 
Project”

2 Enter 
project 
properties

4 Check 
extraction 
configuration 
and save 
project

5 Add/change 
grid files/ 
templates 
(optional)

7 Run the 
extraction 
sets in the 
project

6 Add/change 
protocols 
(optional)
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Instructional overview
Figure 3 Project Explorer with expanded extraction sets

project A grouping of information that contains one or more extraction sets that 
define the files to use in the extraction.

extraction set Each group that contains a microarray image file, grid template (or grid 
file) and protocol within a project. This term is used both before and after 
extraction.

grid template Grid information from Agilent design files or grid files stored in the 
database. A grid template includes feature annotation and general 
geometry about the microarray (number of rows, columns, subgrids, 
feature spacings), which is used to find spots before data analysis takes 
place. Although not specific to any microarray image, grid template 
information is usually applied to the image for which the template was 
designed.

grid file Grid files are required in order to do feature extraction for non- Agilent 
images. Rarely, the automatic grid placement of Agilent images using a 
grid template may produce an incorrect grid, which will also require the 
use of a user- generated grid file. When using a grid file, extraction uses 
the nominal and “found” spot locations specific to the image from which 
the grid file was created. Grid files are created in the Feature Extraction 
for CytoGenomics program using a microarray image file and a microarray 
layout file (such as an Agilent Design file or a .GAL [GenePix Array List] 
file). The grid file contains the locations of the “found” spots if the 
“Calculate spot size and centroids” option is run before the file is saved. 
You can create grid templates from grid files, although the templates have 
only geometry information, no found spots.

protocol A list of steps and parameter values that define the data analysis 
algorithms and calculations used for feature extraction of a microarray 
image or images.

Extraction Set

Image File

Grid Template (design)

Protocol

Grid File
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General Instructions
General Instructions

Step 1. Create a Standard Project

• If the Feature Extraction for CytoGenomics program is not already 
running, start the program according to the instructions given above. 
See “Starting the program” on page 6

Feature Extraction automatically creates a standard project 
(FE_Project1) every time you start the program. The Feature Extraction 
main window appears with the Project1 work window and an empty 
Extraction Set Configuration tab window. 

Figure 4 Feature Extraction main window components

You can change where and how the project work window and the 
browser panes dock when you start the program. To learn more about 
working with this interface, see the Feature Extraction for 
CytoGenomics User Guide. 

Standard Toolbar

Grid Template 
Browser Pane

FE Protocol 
Browser Pane

Project Explorer 
Pane

QC Metric Set 
Browser Pane

PROJECT WORK WINDOW

FE Project Tools
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General Instructions
Step 2. Enter the project properties

1 Click the Project Properties tab to view the default project properties.

2 To change a default setting, select a property and click the down arrow 
that appears on the right column. Choose from the available options.

Figure 5 Default project properties for a standard project 

You can run Feature Extraction for one or more Agilent images generated 
by the Agilent scanner with these default project properties. You can also 
set up and run multiple extractions with a combination of Agilent and 
non- Agilent images.

Step 3. Add image files (extraction sets) to the project

1 In the Project Explorer, right- click FE_Project1, and click Add 
Extraction.

2 Select one or more images, and click Open. 

• To select multiple images at a time, hold down the Ctrl key and select 
the images.
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General Instructions
• You can also add one or more image files by dragging and dropping 
them from the folder to the open project in the Feature Extraction 
window.

Any extraction set that is missing the required components, such as grid 
template or protocol, shows a lightning bolt in Project Explorer and a “?” 
in the icon of the missing component. If a grid template is not in the 
database, you must import it from within the Agilent CytoGenomics 
program before you run the extraction.

If grid templates are not assigned automatically, or you want to use a 
different grid template or protocol, you can assign them manually. See 
Step 4 “Step 4. Assign grid template/grid file to the extraction set 
(depending on type of images)” on page 14 and Step 5 “Step 5. Assign a 
protocol to the extraction set (optional)” on page 16.

Step 4. Assign grid template/grid file to the extraction set (depending on type of 
images)

Agilent images By default, if the required grid templates are in the 
database, when you add Agilent tiff images to the project, Feature 
Extraction will automatically associate the appropriate grid templates to 
the extraction sets. You can also assign a grid template or grid file to the 
Agilent image.

To assign a grid template for Agilent images:

1 Expand the extraction set.

2 Select a grid template from the Grid Template Browser, hold down the 
mouse button and drag it to the second position of the extraction set in 
Project Explorer. 

3 Let go of the mouse button to drop it at this position.

To assign a grid file for Agilent images:

1 Right- click the second position of the expanded extraction set and click 
Select Grid File.

2 Select the grid file, and click Open.

The grid file name will appear in the extraction set, along with the grid 
template on which it is based.
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General Instructions
Non-Agilent images You must assign a grid file to non- Agilent images in 
the project. The extraction automation feature is not supported for 
non- Agilent images. Feature Extraction for CytoGenomics will not extract 
non- Agilent images that are missing grid files or protocols.

To assign a grid file for non- Agilent images:

1 Right- click the second position of the expanded extraction set and click 
Select Grid File.

2 Select the grid file, and click Open.

AMADID is the 
Agilent MicroArray 

Design IDentifier.

Agilent microarray images scanned with an Agilent scanner For Agilent 
microarray images with barcode information included in the image, the 
program selects a grid template from the database using the AMADID 
portion of the barcode associated with the image file. If there are grid 
templates for that AMADID that come from multiple design files, the 
program selects the grid template from the most recently created Agilent 
design file. To add a barcode if the image has none, see the Feature 
Extraction for CytoGenomics User Guide. 

For this automated assignment to work, the grid template must exist in 
the database. If it does not, you can interactively associate a grid template 
or grid file with the extraction set. See page 14 for details on how to 
assign a grid template or grid file.

Agilent uses barcode information for many workflow automation and data 
tracking steps. Inclusion of the Agilent barcode information in the TIFF 
file helps ensure that the data is quickly, easily and accurately processed 
and that informatics programs know how to analyze the results.

Agilent microarray images scanned with a non-Agilent scanner For Agilent 
microarray images generated on Roche NimbleGen MS 200 scanners, select 
Innopsys InnoScan scanners or select Tecan scanners, the program selects 
a grid template using the same method described above for Agilent 
microarray images scanned with an Agilent scanner. 

Non-Agilent images scanned with an Agilent scanner Non- Agilent image files 
from an Agilent scanner do not point to grid information that the Agilent 
Feature Extraction program can read. Therefore, when you load the 
non- Agilent image file, you must add a grid file that you have already 
created. 

See Chapter 3 in the Feature Extraction for CytoGenomics User Guide to 
learn how to create grid files.
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Step 5. Assign a protocol to the extraction set (optional)

Automatically assigned protocols come from two sources: a default 
protocol associated with the grid template, or a project level default 
protocol. You select which of these options has the higher priority. (See 
the Feature Extraction for CytoGenomics User Guide to learn how to 
associate a protocol with a grid template and where to enter the project 
level default protocol.) You can also add a protocol to the extraction set 
manually.

To add a protocol manually:

1 From the Protocol Browser select a protocol, hold down the mouse 
button and drag it to the third position of the extraction set.

2 Release the mouse button to drop the protocol onto the third position 
of the set.

Feature Extraction for CytoGenomics can run analyses on Agilent 1- color 
gene expression (GE1), 2- color gene expression (GE2), CGH, CGH+SNP, 
ChIP, miRNA, and non- Agilent 2- color GE (GE2- nonAT) microarray images 
scanned on the Agilent scanner. Feature Extraction for CytoGenomics 
contains a protocol for extracting CGH and CGH+SNP image types. To run 
extractions on other Agilent image types (GE1, GE2, ChIP, and miRNA), or 
on non- Agilent 2- color GE array images, you must first download the 
required protocol from the Agilent Genomics website, import it into 
Feature Extraction for CytoGenomics, and then assign it to the 
appropriate grid template. See the Feature Extraction for CytoGenomics 
User Guide for instructions on importing protocols and associating a 
protocol with a grid template. 

CAUTION These Feature Extraction Protocols were optimized using data from Agilent catalog 
arrays, which have many replicated probes and validated Negative Control probes. If 
custom arrays without enough replicated probes are used, or arrays with custom 
probes designated as Negative Control probes, the default Feature Extraction Protocols 
may not be optimal. The Feature Extraction Protocol optimization also uses Agilent's 
default lab protocols; that is, label, hybridization, wash, and scanner procedures.
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Step 6. From within the Agilent CytoGenomics program, add design files for the 
images you intend to extract (optional)

Every extraction set must have an image file, assigned grid template/grid 
file and protocol. Grid templates and protocols for Agilent images are 
loaded to the extraction set automatically by the program, if the grid 
template associated with the loaded image’s design file is available in the 
database. If the design file in the database, it is displayed in the Grid 
Template Browser. (To update the list, right- click in the Grid Template 
Browser, and select Refresh.) If the design file is not in the database, you 
must import it manually from within the Agilent CytoGenomics program 
using the instructions below.

1 Launch Agilent CytoGenomics 2.5.

2 From the Supporting Files tab, click Import Design. 

3 Select a design file (format *.xml) to import into the CytoGenomics 
database.

See the CytoGenomics help system for more information on importing 
design files. 

Step 7. Change QC metric set associated with the protocol to monitor QC metrics 
(optional)

When the microarray processing protocols are similar and monitoring 
run- to- run consistency is an important goal, Feature Extraction for 
CytoGenomics can help monitor this consistency with the QC metric sets. 

To change the QC metric set associated to the Feature Extraction for 
CytoGenomics protocol:

1 In the FE Protocol Browser, double- click a protocol to open the FE 
Protocol Editor.

2 Select Protocol Properties to see the protocol properties.

3 Under General, click the cell next to Metricset.

4 Click the down arrow, and select the QC metric set appropriate for your 
microarray application.

If a metric set you want to use is not available in the metric set list, 
you must first import it to the database. 

To import a QC metric set into the database:
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General Instructions
1 Select View > QC Metric Set Browser from Feature Extraction for 
CytoGenomics main window, if it is not already visible.

2 The QC Metric Set Browser displays all of the default metric sets and 
custom metric sets in the database. Custom metric sets are created 
using the Quality module in the Agilent CytoGenomics program. 
Right- click in the QC Metric Set Browser and select Import to import 
metric sets that are not shown in the QC Metric Set Browser, or 
select Refresh to update the list.

The default QC metric sets installed with the Feature Extraction 
software are read- only and cannot be removed from the database. 
However, you can remove or change a QC metric set associated with the 
protocol and then save it as a new protocol with a different name. 

To remove a QC metric set from the protocol:

• Select <Set empty> from the metric set list in the Protocol 
Properties.

5 Click Save As to save the new protocol.

QC metric sets A default CGH QC metric set is loaded into the database 
when the Feature Extraction for CytoGenomics software was installed. 

If you remove a QC metric set, updates of QC metric sets are also 
available at www.agilent.com/chem/feqcmetrics, if you need to manually 
download and install them in Feature Extraction for CytoGenomics. 

When you create QC metric sets using Agilent CytoGenomics, you can 
associate them to protocols in Feature Extraction for CytoGenomics. When 
a project associated with a QC metric set is run, the Feature Extraction 
for CytoGenomics program summarizes the metric statistics on each 
microarray’s QC report and shows how the results compare to the 
thresholds (if any) defined in the metric set. It also reports this 
information in the output files in the statistics table.

CAUTION Agilent-supplied QC metric sets are intended to assist users in monitoring microarray 
processing issues. They were not developed to detect microarray manufacturing 
issues.
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General Instructions
Step 8. Save the project 

1 Select File > Save As.

By default, your projects are saved in one of the following file paths:

• For Windows 7: C:\ProgramData\Agilent\FeatureExtractionCyto\ 
FEProjects

• For Windows XP: D:\Documents and Settings\All Users\ 
Application Data\Agilent\FeatureExtractionCyto\FEProjects

2 To save in a different location, go to or create the folder for your 
projects.

3 Type a project name, and click Save.

Step 9. Run Feature Extraction

• Click the Project Run mode On/Off button on the Feature Extraction 
Project toolbar , or select Project > Start Extracting. 
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Setting up an On-Time project to extract Agilent image files in real time
Setting up an On-Time project to extract Agilent image files in real time

Instructional overview
An On- Time project lets you set up the Feature Extraction software to 
automatically extract Agilent microarray image files as they are 
transferred from the Agilent scanner to a folder of your choosing. 

Follow the workflow below and the instructions on the next pages to get 
started.

Start 
Here!

Set up and 
run Agilent 
files in real 
time

3 Set the 
results path 
and formats

1 Create an 
“On-Time” 
project

2 Set the 
incoming 
image path

4 Set the 
Feature 
Extraction 
termination 
criteria

5 Set other 
properties 
and save the 
project

6 Run Feature 
Extraction

NOTE
 On-Time projects work only with Agilent microarrays scanned on the Agilent scanner.
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General Instructions

These instructions help you set up the program to run a batch of Agilent 
microarray images in real time as they arrive from the Agilent scanner to 
a folder of your choosing. 

Step 1. Create an on-time project

• Select File > New > On- Time Project.

Note that you do not add extraction sets to on- time projects.

Figure 6 On-Time Project Properties window 
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General Instructions
Step 2. Enter the incoming image path

1 Click the cell next to Incoming Image Folder, and select the path for 
your scanned images.

2 Click OK.

The software assigns the appropriate grid template to each of the 
Agilent microarrays and the appropriate protocol included in the Grid 
Template Properties sheet.

Step 3. Enter termination criteria

1 Click the cell next to Use Run Duration Time Out, and select True.

2 If not expanded, expand the Duration Time folder.

3 Use the sliders to enter 0 for Days, 2 for Hours and 30 for Minutes.

Figure 7 On-Time Project run terminating
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Step 4. Change QC metric set associated with a protocol to monitor QC metrics 

To change the QC metric set associated to the Feature Extraction protocol:

1 In the FE Protocol Browser, double- click a protocol to open the FE 
Protocol Editor.

2 Select the Protocol Properties tab to see the protocol properties.

3 Under General, click the cell next to Metricset.

4 Click the down arrow, and select the QC metric set appropriate for your 
microarray application.

If a metric set you want to use is not available in the metric set list, 
you must first import it to the database. 

To import a QC metric set into the database:

1 Select View > QC Metric Set Browser from Feature Extraction main 
window, if it is not already visible.

2 Right- click in the QC Metric Set Browser and select Import to import 
a metric set. 

The default QC metric sets installed with the Feature Extraction 
software are read- only and can not be removed from the database. But 
you can remove a QC metric set from the protocol. 

To remove a QC metric set associated with the protocol:

• Select <Set empty> from the metric set list in the Protocol 
Properties.

5 Click Save As to save the new protocol.

Step 5. Save the project 

1 Select File > Save As.

By default, your projects are saved in one of the following file paths:.

• For Windows 7: C:\ProgramData\Agilent\FeatureExtractionCyto\ 
FEProjects

• For Windows XP: D:\Documents and Settings\All Users\ 
Application Data\Agilent\FeatureExtractionCyto\FEProjects

2 To save in a different location, go to or create the folder for your 
projects.

3 Type a project name, and click Save.
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Step 6. Run an extraction

1 Make sure that the scanner is ready.

2 Click the Project Run mode On/Off icon in the Feature Extraction 
Project Tools, or select Project > Start Extracting.

The image files are saved to the Incoming Image Folder as they 
complete scanning and are then extracted automatically.

You can display the progress of the extractions, the Summary Report, 
and the QC Report as you did for the Standard Project extractions.

The Summary Report notes how many metrics are within range for 
each extraction. The QC report for each image contains the values for 
the metrics and an evaluation of whether they were within or exceeded 
the threshold limits.
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General Instructions
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In this book

This book contains brief 
instructions to help you get 
started with your Feature 
Extraction for CytoGenomics 
software. This book shows 
you:

• How to set up and run 
batch extractions of 
existing Agilent and 
non- Agilent image files

• How to set up and run 
batch extractions of Agilent 
image files in real time
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